Download

Install: FreeBSD


Important!

If you already upgraded your Chunkservers to v. 3.0.83 or higher, please DO NOT downgrade them!

In MooseFS Chunkserver v. 3.0.83 we changed Chunk header from 5k to 8k (see changelog) - it means, that Chunkserver older than 3.0.83 cannot "understand" new Chunk header, which may lead to potential data loss!


We support FreeBSD 9.3, 10 and 11 (FreeBSD 11 is supported since MooseFS 3.0.88)

To install/update MooseFS from officially supported repository follow the instructions below:

Note: If you want to install MooseFS from moosefs-2 branch, please replace moosefs-3 with moosefs-2 in the following URLs and install moosefs2-* packages instead of moosefs3-*.

First of all you need to create a file moosefs.conf in directory /etc/pkg with following contents:

After that do:
# pkg update


and one of the following commands depending on the components that you are about to install:


Running the system

After first successful installation the system needs basic configuration. You can find more details on running the system in Documentation section available from tabs at the top of the page.

Update from previous versions

To install 2.0.x the packages from 1.6.x/1.7.x should be uninstalled without removing metadata information. It is strongly advised to backup the metadata before the update.

Once the system is running in version 2.0.x the normal update procedure from package manager should work.




Follow us
CONTACT US
Core Technology 57 West 57th Street,
New York City,
New York, 10019
Tel: +1 646-416-7918
Fax: +1 646-416-8001
Contact form:
* - information required